Centos6.5升级glibc

  • A+
所属分类:Linux
又拍云upyun

场景需求

注意更新系统库存在一定的风险, 请谨慎操作
默认的Centos6.5 glibc版本最高为2.12, 而在进行Nodejs开发时项目所依赖的包往往需要更高版本的glibc库支持, 因此在不升级系统的前提下, 需要主动更新系统glibc库. 一般遇到错误libc.so.6: version GLIBC_2.14 not found时表示需要对glibc进行升级了.

glibc版本

查看系统glibc库版本可使用如下命令:


Centos6.5输出如下glibc版本列表, 从此图可以看出系统最高支持glibc的2.12版本:

glibc

另外, 执行$ ll /lib64/libc**可以看到此时的libc.so.6是libc-2.12.so的别名, 如下图所示:

glibc

glibc安装

首先, 点击此处下载glibc点击下载, 得到glibc-2.14.tar.gz使用如下命令解压glibc-2.14.tar.gz:

当前目录下得到目录glibc-2.14, 执行$cd glibc-2.14命令进入目录, 依次执行如下命令编译安装glibc-2.14:

glibc软链

安装完成后, 建立软链指向glibc-2.14, 执行如下命令:

注意

删除libc.so.6之后可能导致系统命令不可用的情况, 可使用如下方法解决:

如果上述更新失败可使用如下命令还原:

此时查看系统glibc版本如下图所示:

glibc

可以看到当前glibc最高版本为2.14, libc.so.6软链指向如下图所示:

glibc

weinxin
微信公众号
扫一扫关注运维生存时间公众号,获取最新技术文章~
默北

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

目前评论:1   其中:访客  1   博主  0

    • 淡定的但丁 0

      都是泪,前几天升级RHEL5上的GLIBC用来支持NODEJS。。。直接升到崩溃了,而且还忘了打快照!!!云环境下也进不去救援模式。
      各位一定得小心操作 啊!能备份就多备份! :sad: