ELK 产品支持的平台和软件(1st)

在搭建ELK日志分析平台前,先要搞清楚各个组件所支持依赖的系统平台和软件版本。如下表:

1. elasticsearch/logstash 所需JVM版本

ttlsa.com  Oracle JRE
1.6
Oracle JVM
1.7u55+
Oracle JVM
1.8u20+
IcedTea OpenJDK
1.6
IcedTea OpenJDK
1.7.0.55+
IBM
JVM 6
IBM
JVM 7
Azul
Zing
ES 1.0.x beats beats beats beats beats beats beats beats
ES 1.1.x beats beats beats beats beats beats beats beats
ES 1.2.x beats beats beats beats beats beats beats beats
ES 1.3.x beats beats beats beats beats beats beats beats
ES 1.4.x beats beats beats beats beats beats beats beats
ES 1.5.x beats beats beats beats beats beats beats beats
ES 1.6.x beats beats beats beats beats beats beats beats
ES 1.7.x beats beats beats beats beats beats beats beats
ES 2.0.x beats beats beats beats beats beats beats beats
Logstash 1.x beats beats beats beats beats beats beats beats
Logstash 2.x beats beats beats beats beats beats beats beats

2. elasticsearch/logstash/beats 所支持的系统

ttlsa.com CentOS/RHEL
6.x/7.x
Oracle Enterprise
Linux 6/7
with RHEL
Kernel only
Ubuntu
12.04/14.04
SLES 11/12 OpenSuSE
13.2
Windows Server
2012/R2
Windows Server
2008
Debian
7
Solaris/SmartOS
ES 1.0.x beats beats beats beats beats beats beats beats beats
ES 1.1.x beats beats beats beats beats beats beats beats beats
ES 1.2.x beats beats beats beats beats beats beats beats beats
ES 1.3.x beats beats beats beats beats beats beats beats beats
ES 1.4.x beats beats beats beats beats beats beats beats beats
ES 1.5.x beats beats beats beats beats beats beats beats beats
ES 1.6.x beats beats beats beats beats beats beats beats beats
ES 1.7.x beats beats beats beats beats beats beats beats beats
ES 2.0.x beats beats beats beats beats beats beats beats beats
Logstash 1.x beats beats beats beats beats beats beats beats beats
Logstash 2.x beats beats beats beats beats beats beats beats beats
Beats 1.0.x Beta* beats beats beats beats beats beats beats beats beats

3. kibana支持的浏览器

 ttlsa.com IE9 IE10+ Firefox Chrome Safari(Mac) Safari(iOS) Chrome (Android)
Kibana 3.1 beats beats beats beats beats beats beats
Kibana 4 beats beats beats beats beats beats beats

4. ELK之间的兼容性

a. 支持的shield版本

Shield Version ES Version
1.0x 1.4.2 and greater
1.1.0 1.4.2 and greater
1.2.0 1.5.0 and greater
1.3.0 1.5.0 and greater
2.0.0 2.0.0

b. 支持的marvel版本

Marvel Version ES Version Compatibility Shield Version Compatibility
1.2.x 0.90.9 - 1.4.x not supported
1.3.x 0.90.9 and greater 1.0.x and greater
2.0.0 2.0.0 2.0.0

c. 支持的kibana版本

Kibana Version ES Version Compatibility Shield Version Compatibility
3.1x 0.90.9 and greater 1.0.x-1.2.x
4.0.0-4.1.x 1.4.x-1.7.x 1.0.x-1.3.x
4.2.0+ 2.0.0 2.0.0

d. 支持的beats版本

Beats Version ES Version Compatibility Logstash Version Compatibility Kibana Version Compatibility
1.0.0 Beta* 1.4 and higher 1.4 and higher 4.1 and higher

e. 支持的watcher版本

Watcher Version ES Version Compatibility
1.0.0 1.5.0 and greater
2.0.0 2.0.0

f. 支持的logstash版本

Logstash Version ES Version Compatibility Shield Version Compatibility
1.5.x 1.0.0 and greater 1.0.0 and greater
2.0.x 1.0.0 and greater 1.0.0 and greater

logstash 1.5.x 版本仅支持ES 2.0.0 以及更高版本的HTTP协议。

在开始ELK之前,请务必理清上面表格的需求再继续。

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

目前评论:3   其中:访客  3   博主  0

  1. Aceslup 4

    那么多组件,如何了解功能呢

  2. Aceslup 4

    继续往下研究。

  3. elk 5

    楼主线下elk培训不? 最近在研究elk看到贵博客